Neues Thema starten

Core Dienst lässt sich nicht starten

Hallo,

wir haben die Software heute frisch installiert und haben den ersten Shop (Hitmeister) angelegt. Leider startet der Core Dienst nicht. Wir benutzen nicht Antivira. Unser Antivirus ist abgeschaltet. Hat jemand eine Idee? Hier die Logs von heute:

Time: 05.03.2015 13:32:03 Type: Error - Message: Could not read unicorn login data from registry
Time: 05.03.2015 13:32:03 Type: Error - Message: Unhandled Exception WhereSelectArrayIterator`2::MoveNext() ==> RegistryAccess::set_Path(): KeyNotFoundException
|--Message: Registry path SOFTWARE\marcos software\unicorn 2\Instanz 2 could not be found!
|--Source: Common
|--TargetSite: Void set_Path(System.String)
|
\--StackTrace: at Unicorn2.Common.RegistryAccess.set_Path(String value)
at Unicorn2.Common.RegistryAccess.set_SubPath(String value)
at Unicorn2.Common.RegistryAccess..ctor(String folder, Boolean absolute, Boolean writeAccess)
at Unicorn2.Common.RegistryAccess..ctor(String instancefolder, Boolean writeAccess)
at Unicorn2.Common.Database.Unicorn.UnicornLogin..cto r(String instancefolder, Boolean writeAccess)
at Unicorn2.Common.Database.Unicorn.UnicornLogin..cto r()
at Unicorn2.UpdateService.UpdateService.<GenerateThre adUpdateService>b__5()



Hat jemand eine Idee? Wir danken im Voraus.


Nachtrag: Diese Meldung haben wir noch soeben bekommen:

05.03.2015 16:56:28 Warning Unhandled Exception WhereSelectArrayIterator`2::MoveNext() ==> ControlCollection::GetChildIndex(): ArgumentException
|--Message: "child" ist kein untergeordnetes Steuerelement dieses übergeordneten Elements.
|--Source: System.Windows.Forms
|--TargetSite: Int32 GetChildIndex(System.Windows.Forms.Control, Boolean)
|
\--StackTrace: bei System.Windows.Forms.Control.ControlCollection.Get ChildIndex(Control child, Boolean throwException)
bei System.Windows.Forms.Control.ControlCollection.Set ChildIndexInternal(Control child, Int32 newIndex)
bei Unicorn2.FormMain.ShowMarket()

Hallo E.Nahm_UG,

da scheint bei der Installation etwas grundsätzliches schief gelaufen zu sein.
Wie ich sehe wurde Instanz 2 erstellt, das heißt du hattest es schonmal probiert, bzw. das Programmverzeichnis war nicht leer ?

Kannst du bitte einmal die jetzige Installation komplett löschen (bitte auch "von Hand" nachsehen, dass wirklich alles weg ist - vorallem in der Registry (LocalMachine -> Software -> marcos software, als auch die MSSQL Instanz (!!!)), danach den Rechner neu starten. Bitte prüfe auch, dass du alle Windows Updates installiert hast und das .Net Framework aktuell ist (4.5.2 ist glaube ich die derzeit aktuellste Version) den Installer nochmal frisch von unserer Seite runterladen und das Setup mit vollen Administratorberechtigungen (!!!) ausführen ? Bitte während der Installation alle Antiviren Programme, etc. kurzzeitig anhalten. Falls das Problem danach immer noch auftreten sollte schreib uns bitte einmal etwas zu deinem System, welches Windows du einsetzt, welche Architektur (32 oder 64 Bit), etc.

Grüße,
Marc

Ich danke für die schnelle Antwort.

Unser Firmencomputer ist derzeit in Wartung und Windows wird neu installiert. Danach wird das Programm neu installiert und ich melde mich kurz zurück.

Mit besten Grüßen

Emanuel Nahm
Emanuel Nahm UG (haftungsbeschränkt)

Hi Emanuel,

wenn ihr Avira AntiVirus installiert habt, kann es sein, dass ihr noch nicht die aktuellste Virusdefinition bekommen habt (ggf. hat Avira diese auch noch nicht herausgegeben).
Avira AntiVirus hat (auch wenn Ausnahmen für unicorn 2 erzeugt werden dennoch) unsere Core.exe blockiert, bzw in Quarantäne verschoben. Dies ist aber ein Fehlalarm. Wir haben dies Avira gemeldet und von dort die Bestätigung hierfür am 04. März erhalten, sowie die Information, dass eine Fehlerbehebung seitens Avira in einer der nächsten Virendefinitions-Updates für alle Avira Kunden einfließt.

Siehe hierzu auch: https://www.facebook.com/marcossoftw...53245918073865
Wie du (sobald Avira die Virendefinition geupdatet hat) die Dienste -bei Bedarf (!)- wieder manuell hinzufügen kannst findest du in unserer Dokumentation: http://dokumentation.marcos-software...auf_einmal_.3F

Grüße,
Marc

Wir haben Unicorn 2 nun auf dem neu aufgesetzten Rechner installiert. Nun haben wir das Problem, dass wir den Hitmeister-Shop gar nicht aktivieren könnnen. Denn das Programm sagt uns, die Logindaten sind falsch. Dies ist definitiv nicht so. Über den Browser funktioniert der Login mit diesen Daten problemlos.

Gibt es hierfür auch ne Lösung? 

Mit besten Grüßen

Emanuel Nahm

Hallo Emanuel,

du musst für den Zugang zu Hitmeister den Client Key und den Secret Key angeben, siehe dazu auch: 
http://forum.marcos-software.de/foru...key-secret-key

Grüße,
Marc

Danke für die schnelle und kompetente Hilfe.

Seit heute scheint Hitmeister problemlos zu laufen.

Mit besten Grüßen

Emanuel Nahm
Emanuel Nahm UG (haftungsbeschränkt)

 

Hallo Emanuel,

na das hört man doch gerne =)
Ein Lob an und zu ermutigt, auch weiterhin den gleichen Fleiß zu investieren!

Grüße,
Marc

PS: Ich mach den Thread an der Stelle zu, da das (eigentliche) Problem ja mittlerweile behoben ist.